GQ Electronics Technical Support Forum Active Users: / Visits Today:
Highest Active Users:
GQ Electronics Technical Support Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 GQ Electronics Forums
 2.GQ Geiger Muller Counter
 help for install Geigerlog

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
engelbert Posted - 03/20/2022 : 03:38:45
I have install Geigerlog from Ullix and have some truble. i get a mistake:
--------------------
d@-Satellite-L350:~$ './geigerlog'
Traceback (most recent call last):
File "./geigerlog", line 91, in <module>
from gsup_utils import * # includes import of gglobs
File "./geigerlog/gsup_utils.py", line 76, in <module>
import sounddevice as sd # sound output input
File "/home/hd/.local/lib/python3.8/site-packages/sounddevice.py", line 71, in <module>
raise OSError('PortAudio library not found')
OSError: PortAudio library not found
-------------------
The solution is install sounddevice by this instruction:
sudo apt-get install libportaudio2
3   L A T E S T    R E P L I E S    (Newest First)
ullix Posted - 03/23/2022 : 01:41:02
I am bit at a loss to understand what is going on with your setup. First you say you get the OS-error, then you seem to suggest a solution, now you say, no, you didn't, but then you are running GeigerLog anyway, which is only possible when you did overcome the error? Which is it?

If you were able to find a correction, then I'd like to know what the problem and the solution was, because I'd either fix it in the code, if it is a bug in GeigerLog (doesn't look like it) or can advise users on what to do if the problem is elsewhere.

Regarding connecting and running: please, see the manual in the chapter about the GMC counters.

WiFi is possible, however, due to a bug and deficiency in the firmware of the counter, it is not trivial to do. You need to install, run and modify an Apache server and install some php software. Again, it is all in the manual in sufficient detail to replicate, chapter "WiFi Devices managed by GeigerLog".

An easier way would actually be to ignore the build-in WiFi of your GMC-320 counter and use a Raspi as a "converter", see this post: "WiFi Enabling a GMC-300E+ Counter" http://www.gqelectronicsllc.com/forum/topic.asp?TOPIC_ID=9836
engelbert Posted - 03/22/2022 : 06:06:14
@ullix, No i just trying to help.

But i have another question.
I have succesfully installed the geigerlog software (thanks for that). i don't understand how i contect it to my laptop
Do i need a usb-serial cable or can i use wifi. usb-audio cable is connected (the audio button is green, GMC button is red) .
and when i use wifi what are the settings

Thans in advance.
ullix Posted - 03/21/2022 : 00:05:42
I am not sure I understand: are you just reporting an error, or are you already including the solution?

If you still have the question, I would need more details on the problem, like type of OS (looks like Linux), versions. Best is to start GeigerLog with: 'geigerlog -dvwR' and provide to me the resulting 'geigerlog.stdlog' file (find it in the data directory). You can use the GeigerLog sourceforge site under "Discussion" to post this file (https://sourceforge.net/p/geigerlog/discussion/ )

GQ Electronics Technical Support Forum © Copyright since 2011 Go To Top Of Page
Generated in 0.08 sec. Snitz's Forums 2000