GQ Electronics Technical Support Forum Active Users: / Visits Today:
Highest Active Users:
GQ Electronics Technical Support Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 GQ Electronics Forums
 1.Geiger Counter World Map(www.GMCmap.com)
 Link Server Failed
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

HeinBloed

3 Posts

Posted - 02/24/2022 :  04:52:26  Show Profile  Reply with Quote
I already wrote this yesterday, but this thread was deleted (and even my whole account…) - don't know why? Not very supportive…
I will try it again:
My device (GMC 500+) didn't get a connection to GMCMap (shows Link Server failed).
All data is correct. My devive worked for over 2 years, but after a power off, problems appeared.

I did a factory reset now, deleted device and created/registered a new one. Still the same.

WiFi is connected, but when storing data (period = 1 for test purposes at the moment) it shows "Wifi Data send failed", and when testing server connection it shows "Link server failed"

I noticed a shift in the IP. After factory reset, it showed an IP 192.168.1.xx, which should be correct (within IP range of my WiFi Access point), but after a few moments it shows an IP 192.168.0.xx

Maybe that's the reason for not getting a connection. Is there a possibility to fix the (static) IP?

Thanks for your support

GQ GMC 500+
Reply #1

EmfDev

1782 Posts

Posted - 02/25/2022 :  10:06:09  Show Profile  Reply with Quote
Hi HeinBloed, server crashed the other day and looks like 1 day of data was lost.

Can you try to do a Reset WiFi Module under wifi?
Go to Top of Page
Reply #2

HeinBloed

3 Posts

Posted - 02/27/2022 :  09:59:54  Show Profile  Reply with Quote
Done! After this, it shows "connected", but it's always a wrong IP range, something with 192.168.0.xxx, and that's not an IP of my WiFi.

I then put my mobile and created a mobile hotspot and wrote the access data to my GMC 500+. It connected, but it still shows the same IP, and error message "Link server failed".

Isn't there a possibility to define a a static IP via an AT command?

GQ GMC 500+

Edited by - HeinBloed on 02/27/2022 10:06:47
Go to Top of Page
Reply #3

HeinBloed

3 Posts

Posted - 02/28/2022 :  02:46:18  Show Profile  Reply with Quote
Meanwhile, I solved it on my own. I found an AT command to set a specific fixed IP:
AT+CIPSTA=”192.168.1.25”
I used the GQ GMC Data Viewer software and used this command in the 'terminal' section.
You have to use the command text 'AT+CIPSTA' and ' =”192.168.1.25” ' in the second section (Hexadecimal parameters), with 'text parameters' checked.

Immediately my device connected with my WiFi and I now get acccess. Maybe this will help others with the same problem.

GQ GMC 500+
Go to Top of Page
Reply #4

EmfDev

1782 Posts

Posted - 03/01/2022 :  17:59:36  Show Profile  Reply with Quote
That is great!
Go to Top of Page
Reply #5

PRA7

5 Posts

Posted - 03/30/2022 :  14:46:55  Show Profile  Reply with Quote
500+ had been connecting fine via wifi but now getting Link Server Failed error.

Performed the wifi reset, then factory reset, manually entered info and also used Data Viewer tool. Still no luck. It connects to network and gets validated IP. Data sends fine via Data Logger app (USB).

Also power cycled and pulled battery.

Plus searched forums with related topic.

Any suggestions?
Go to Top of Page
Reply #6

EmfDev

1782 Posts

Posted - 03/30/2022 :  15:32:53  Show Profile  Reply with Quote
Can you check the signal strength? And also check the website and url. Should be www.gmcmap.com and log2.asp
Go to Top of Page
Reply #7

PRA7

5 Posts

Posted - 03/30/2022 :  17:34:20  Show Profile  Reply with Quote
Strength is -51 Excellent
Server and URL are correct
Go to Top of Page
Reply #8

EmfDev

1782 Posts

Posted - 03/31/2022 :  10:17:10  Show Profile  Reply with Quote
It is possible the server response is slow. Have you tried the manual link with your GID and UserID?
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
GQ Electronics Technical Support Forum © Copyright since 2011 Go To Top Of Page
Generated in 0.16 sec. Snitz's Forums 2000