GQ Electronics Technical Support Forum Active Users: / Visits Today:
Highest Active Users:
GQ Electronics Technical Support Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 GQ Electronics Forums
 1.Geiger Counter World Map(www.GMCmap.com)
 Custom Server
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Nikeware

Germany
4 Posts

Posted - 08/26/2023 :  09:04:21  Show Profile  Reply with Quote
Hallo All!

Is it possible to send data direct from device (GMC-500+) to own server?
I created local server in my home intranet and configure device with next:
Server: h**p://localhost:90/
URL: index.php

But "Test connection" command from menu said "Link Server Failed" :(
Periodically I see "WiFi Data Send Failed" message also.

With default server (h**p://gmcmap.com/) and URL (log2.asp) all work fine.

Thanks!
Reply #1

EmfDev

2143 Posts

Posted - 08/28/2023 :  09:56:51  Show Profile  Reply with Quote
Did your server receive the the data? You should respond with "OK.ERR0"
Go to Top of Page
Reply #2

Nikeware

Germany
4 Posts

Posted - 08/29/2023 :  00:45:53  Show Profile  Reply with Quote
quote:
Originally posted by EmfDev

Did your server receive the the data? You should respond with "OK.ERR0"


Thank you for answer!

If I try enter the url direct in browser, like this:
h**p://localhost:90/index.php?AID=0230111&GID=0034021&CPM=15&ACPM=13.2&uSV=0.075
it is work fine. Server recieved data and of course answered with "OK.ERR0".

But it is not work direct from device itself.
The "OK.ERR0" answer are there simple text or something another?

If I try enter in the browser url, like:
h**p://gmcmap.com/log2.asp?AID=<my_used_id>&GID=<my_device_id>CPM=15&ACPM=13.2&uSV=0.075
I have answer with "OK.ERR0", but in "Developer Tool" window of the browser (F12) this answer look like 4 lines, were "OK.ERR0" itself placed on the last line.
Go to Top of Page
Reply #3

EmfDev

2143 Posts

Posted - 08/29/2023 :  10:54:00  Show Profile  Reply with Quote
is there any response from the device? Like popup error message?

It is just a simple string OK.ERR0.
Go to Top of Page
Reply #4

Nikeware

Germany
4 Posts

Posted - 08/29/2023 :  23:27:11  Show Profile  Reply with Quote
First, from my side there are some small fail :-)

I need use not "localhost", but real ip of my PC in local intranet where the server itself located, of course :-)
In other words, we must configure GMC device with the next settings, like this:
Server: h**p://192.168.178.10:90/
URL: index.php

Where 192.168.178.10 is my server in my local intranet.

Unfortunately this is also not work :-(

quote:
Originally posted by EmfDev

is there any response from the device? Like popup error message?

It is just a simple string OK.ERR0.


On device, if I try activate "Test connection" command from menu, I see "Link Server Failed" error message and periodically, "WiFi Data Send Failed" also.
Go to Top of Page
Reply #5

ullix

Germany
1107 Posts

Posted - 08/30/2023 :  04:59:09  Show Profile  Reply with Quote
The problem with the GQ counters is that they do not support configuration of ports. But using port 80 requires receiving software to be run as admin. Mostly a bad choice.

I have added to GeigerLog a "Relay" software, which is run as admin, and translates to any port you want.

All GeigerLog stuff is found here: https://sourceforge.net/projects/geigerlog/

But this relay is only avaialble in a pre-release version of GL1.5. Take the latest from here: https://sourceforge.net/p/geigerlog/discussion/devel/

Then in the gtools subdir of GeigerLog find the GLrelay.py software and instructions for use.

Go to Top of Page
Reply #6

Nikeware

Germany
4 Posts

Posted - 08/30/2023 :  10:19:16  Show Profile  Reply with Quote
quote:
Originally posted by ullix

The problem with the GQ counters is that they do not support configuration of ports.



The problem is probably something else. I have reconfigured my local server so that it
now works without specifying a port. Something like this:
Server: h**p://192.168.178.10/
URL: index.php

Nothing has changed. Test connection is failed. Please note that I have tried
to access this address from my other home devices and everything works fine.

After that, I transferred this code to my server on the Internet to an address like: h**p://gmc.myhome.com/
The result is the same error.
Go to Top of Page
Reply #7

ullix

Germany
1107 Posts

Posted - 08/30/2023 :  22:33:36  Show Profile  Reply with Quote
Read the references I gave you. It will also direct you to the GeigerLog manual, chapter "WiFi Devices WiFiClient Devices" to learn about a hack needed for an Apached server to make it "unsafe"!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
GQ Electronics Technical Support Forum © Copyright since 2011 Go To Top Of Page
Generated in 0.06 sec. Snitz's Forums 2000