GQ Electronics Technical Support Forum


GQ Electronics Technical Support Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 GQ Electronics Forums
 GQ Geiger Muller Counter
 GMC-300E Plus not counting the ticks anymore
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

leliep

Germany
3 Posts

Posted - 11/25/2016 :  09:16:24  Show Profile  Reply with Quote
One day after checking the radiation that I received during a medical examination (176 uSv/h), my GMC-300E Plus produces the click sound and lights the green led, but does not count them anymore. the whole statistics values are constantly zero.

I did a factory reset as well as removing the battery for an hour, but still no success. What can I do?

Thanks for your support, -pl

Reply #1

ZLM

1085 Posts

Posted - 11/26/2016 :  15:23:14  Show Profile  Reply with Quote
Your GMC-300E tube may be broken.
Go to Top of Page
Reply #2

leliep

Germany
3 Posts

Posted - 11/27/2016 :  23:56:42  Show Profile  Reply with Quote
quote:
Originally posted by ZLM

Your GMC-300E tube may be broken.




I don't think so, because I can still hear the clicks, loud and clear. They're just no longer counted, averaged etc.
So from what I can see the Tube and the audio part still works. The display also works, but without counting anything. Flatline & all values are zero.

Edited by - leliep on 11/28/2016 00:00:32
Go to Top of Page
Reply #3

liberatorJ

USA
4 Posts

Posted - 11/29/2016 :  03:22:37  Show Profile  Reply with Quote
I have a similar problem. On the 2nd day, my 300E Plus stopped working - that is no clicks, no light on the the LED. I do have a display and sound when I turn it on, but after that, nothing. What constitutes a "broken " tube? How do I get it repaired?

htw
Go to Top of Page
Reply #4

Distelzombie

Germany
188 Posts

Posted - 11/30/2016 :  08:47:07  Show Profile  Reply with Quote
A broken tube cannot be repaired, only replaced. A tube is broken if it has been working for hundreds of thousands of clicks and either suddenly stops or registers way way less clicks. It's a degradation effect. (since a "click" is a high voltage discharge.)
If yours is not like 3 years of constant measuring old, I think you should get a refund. But you'll not get a refund on used brakes for your car, so I don't know...

GMC-300E+ V4.20 with sbt-11a alpha tube

My statements are "stuff-a-hobbyist-says" and not in any way professional.
Go to Top of Page
Reply #5

leliep

Germany
3 Posts

Posted - 12/01/2016 :  02:55:10  Show Profile  Reply with Quote
I returned mine for a refund. Will buy a GMC-320+ instead, hoping that it will work longer...
Go to Top of Page
Reply #6

Distelzombie

Germany
188 Posts

Posted - 12/01/2016 :  03:35:47  Show Profile  Reply with Quote
OK, but note: You don't need to return the whole thing, I hope. The tube should be enough. Also, you could've bought another tube. The tube originally installed is not the best, and better ones do fit or can be made fit.

GMC-300E+ V4.20 with sbt-11a alpha tube

My statements are "stuff-a-hobbyist-says" and not in any way professional.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
GQ Electronics Technical Support Forum © Copyright since 2011 Go To Top Of Page
Generated in 0.09 sec. Snitz Forums 2000