GQ Electronics Technical Support Forum Active Users: / Visits Today:
Highest Active Users:
GQ Electronics Technical Support Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 GQ Electronics Forums
 2.GQ Geiger Muller Counter
 PCB - Repair of GMC-500
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

X-Ray

Germany
2 Posts

Posted - 02/14/2024 :  13:23:00  Show Profile  Reply with Quote
Dear all,
Unluckily an IC got burned on the PCB of my GMC-500.

It was located directly under the black tube in the left upper corner.

It's possible for me to do a repair by my own but sadly I cannot read the label since it's half burned.

Maybe somebody could send met a picture of the same board but possible to recognize the IC?

I think it should a kind of voltage regulator for the high voltage and so the tube doesn't work anymore, but not entirely sure.

The counter is type GMC-500 and on the PCB is printed "GMC6 V5.4"

Thanks a lot!




Reply #1

Damien68

France
780 Posts

Posted - 02/21/2024 :  06:52:01  Show Profile  Reply with Quote
"U12" seems to be an accelerometer used to detect the direction of gravity in order to detect the orientation to give to the display (portrait or landscape).
I also have a GMC-500+ but older on it there is only the imprint of "U4" which is present and mounted. This is the accelerometer on my counter.
seeing how U12 is burned, there must have been an overvoltage on the 3v3 rail or on i2C bus, this could have destroyed other components, maybe not.

Mastery is acquired by studying, with it everything becomes simple
Go to Top of Page
Reply #2

EmfDev

2139 Posts

Posted - 02/22/2024 :  11:22:27  Show Profile  Reply with Quote
Sorry I thought I posted a reply already. Damien is right. That chip is for the accelerometer. Part number is LIS3DH. If you remove it, the counter should still work as normal except the Auto Swivel display.
Go to Top of Page
Reply #3

X-Ray

Germany
2 Posts

Posted - 02/28/2024 :  09:14:27  Show Profile  Reply with Quote
Thanks for the competent replies!

Yes, it was the accelerometer and after removing the component it works apparently like before.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
GQ Electronics Technical Support Forum © Copyright since 2011 Go To Top Of Page
Generated in 0.17 sec. Snitz's Forums 2000